phpMyAdmin Improper Authentication
The advisory, in context
An issue was discovered in phpMyAdmin 4.8.x before 4.8.2, in which an attacker can include (view and potentially execute) files on the server. The vulnerability comes from a portion of code where pages are redirected and loaded within phpMyAdmin, and an improper test for whitelisted pages. An attacker must be authenticated, except in the "$cfg['AllowArbitraryServer'] = true" case (where an attacker can specify any host he/she is already in control of, and execute arbitrary code on phpMyAdmin) and the "$cfg['ServerDefault'] = 0" case (which bypasses the login requirement and runs the vulnerable code without any authentication).
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 4.8 before 4.8.2
Fixed in 4.8.2
3 explicitly affected versions
4.8.0, 4.8.0.1, 4.8.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.8"
},
{
"fixed": "4.8.2"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"4.8.0",
"4.8.0.1",
"4.8.1"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2018-12613
- https://github.com/phpmyadmin/composer
- https://security.gentoo.org/glsa/201904-16
- https://www.exploit-db.com/exploits/44924
- https://www.exploit-db.com/exploits/44928
- https://www.exploit-db.com/exploits/45020
- https://www.phpmyadmin.net/security/PMASA-2018-4
- http://packetstormsecurity.com/files/164623/phpMyAdmin-4.8.1-Remote-Code-Execution.html
- http://www.securityfocus.com/bid/104532