{"id":"GHSA-x394-g9j8-x7mf","aliases":["CVE-2018-12613"],"title":"phpMyAdmin Improper Authentication","description":"An issue was discovered in phpMyAdmin 4.8.x before 4.8.2, in which an attacker can include (view and potentially execute) files on the server. The vulnerability comes from a portion of code where pages are redirected and loaded within phpMyAdmin, and an improper test for whitelisted pages. An attacker must be authenticated, except in the \"$cfg['AllowArbitraryServer'] = true\" case (where an attacker can specify any host he/she is already in control of, and execute arbitrary code on phpMyAdmin) and the \"$cfg['ServerDefault'] = 0\" case (which bypasses the login requirement and runs the vulnerable code without any authentication).","severity":"high","score":8.8,"published":"2022-05-13T01:05:22.000Z","modified":"2024-04-24T17:43:38.520Z","withdrawn":false,"knownExploited":false,"affected":[{"ecosystem":"Packagist","name":"phpmyadmin/phpmyadmin","ranges":[{"events":[{"introduced":"4.8"},{"fixed":"4.8.2"}],"type":"ECOSYSTEM"}],"versions":["4.8.0","4.8.0.1","4.8.1"],"fixed":["4.8.2"]}],"references":["https://nvd.nist.gov/vuln/detail/CVE-2018-12613","https://github.com/phpmyadmin/composer","https://security.gentoo.org/glsa/201904-16","https://www.exploit-db.com/exploits/44924","https://www.exploit-db.com/exploits/44928","https://www.exploit-db.com/exploits/45020","https://www.phpmyadmin.net/security/PMASA-2018-4","http://packetstormsecurity.com/files/164623/phpMyAdmin-4.8.1-Remote-Code-Execution.html","http://www.securityfocus.com/bid/104532"],"sources":[{"name":"OSV","id":"GHSA-x394-g9j8-x7mf","modified":"2024-04-24T17:43:38.520168Z","url":"https://osv.dev/vulnerability/GHSA-x394-g9j8-x7mf"}],"assessments":[{"source":"OSV","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","score":8.8}]}