GHSA-wwfh-28hx-w2r2high
Joomla! Framework Remote Code Injection Vulnerability
The advisory, in context
The Session package 1.x before 1.3.1 for Joomla! Framework allows remote attackers to execute arbitrary code via unspecified session values.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
joomla/session Packagist
Ecosystem versions
Earlier releases before 1.3.1
Fixed in 1.3.1
11 explicitly affected versions
1.0, 1.0-alpha, 1.0-beta, 1.0-beta2, 1.0-beta3, 1.1.0, 1.2.0, 1.2.1, 1.2.2, 1.2.3, 1.3.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "1.3.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.0",
"1.0-alpha",
"1.0-beta",
"1.0-beta2",
"1.0-beta3",
"1.1.0",
"1.2.0",
"1.2.1",
"1.2.2",
"1.2.3",
"1.3.0"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2015-8566
- https://developer.joomla.org/security-centre/637-20151205-session-remote-code-execution-vulnerability.html
- https://github.com/FriendsOfPHP/security-advisories/blob/master/joomla/session/CVE-2015-8566.yaml
- https://github.com/joomla-framework/session
- https://web.archive.org/web/20160603093633/http://www.securityfocus.com/bid/79197