GHSA-vvg7-8rmq-92g7medium6.8
Auth0 WordPress has Improper Audience Validation via Auth0-PHP SDK Dependency
No CVE assignedCheck your stack
The advisory, in context
Description
In applications built with the Auth0-PHP SDK, the audience validation in access tokens is performed improperly. Without proper validation, affected applications may accept ID tokens as Access tokens.
Affected product and versions
Projects are affected if they meet the following preconditions:
- Applications using the Auth0 Wordpress plugin with version between 5.0.0-BETA0 and 5.4.0,
- Auth0 Wordpress plugin uses the Auth0-PHP SDK with versions between 8.0.0 and 8.17.0.
Resolution
Upgrade Auth0 Wordpress plugin to version 5.5.0 or greater.
Acknowledgement
Okta would like to thank Jafar Sadiq (iaf4r) for their discovery and responsible disclosure.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
auth0/wordpress Packagist
Ecosystem versions
From 5.0.0-BETA0 before 5.5.0
Fixed in 5.5.0
9 explicitly affected versions
5.0.0, 5.0.0-BETA0, 5.0.0-BETA1, 5.0.1, 5.1.0, 5.2.0, 5.2.1, 5.3.0, 5.4.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "5.0.0-BETA0"
},
{
"fixed": "5.5.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"5.0.0",
"5.0.0-BETA0",
"5.0.0-BETA1",
"5.0.1",
"5.1.0",
"5.2.0",
"5.2.1",
"5.3.0",
"5.4.0"
]
}