{"id":"GHSA-vvg7-8rmq-92g7","aliases":[],"title":"Auth0 WordPress has Improper Audience Validation via Auth0-PHP SDK Dependency","description":"### Description\nIn applications built with the Auth0-PHP SDK, the audience validation in access tokens is performed improperly. Without proper validation, affected applications may accept ID tokens as Access tokens.\n\n### Affected product and versions\nProjects are affected if they meet the following preconditions:\n\n- Applications using the Auth0 Wordpress plugin with version between 5.0.0-BETA0 and 5.4.0,\n- Auth0 Wordpress plugin uses the Auth0-PHP SDK with versions between 8.0.0 and 8.17.0.\n\n### Resolution\nUpgrade Auth0 Wordpress plugin to version 5.5.0 or greater.\n\n### Acknowledgement\nOkta would like to thank Jafar Sadiq (iaf4r) for their discovery and responsible disclosure.","severity":"medium","score":6.8,"published":"2025-12-17T20:57:09.000Z","modified":"2026-02-04T04:28:48.180Z","withdrawn":false,"knownExploited":false,"affected":[{"ecosystem":"Packagist","name":"auth0/wordpress","ranges":[{"events":[{"introduced":"5.0.0-BETA0"},{"fixed":"5.5.0"}],"type":"ECOSYSTEM"}],"versions":["5.0.0","5.0.0-BETA0","5.0.0-BETA1","5.0.1","5.1.0","5.2.0","5.2.1","5.3.0","5.4.0"],"fixed":["5.5.0"]}],"references":["https://github.com/auth0/wordpress/security/advisories/GHSA-vvg7-8rmq-92g7","https://github.com/auth0/wordpress/commit/b207c6f7fd06507b90c4e6bcc18a857ef9e018de","https://github.com/auth0/wordpress","https://github.com/auth0/wordpress/releases/tag/5.5.0"],"sources":[{"name":"OSV","id":"GHSA-vvg7-8rmq-92g7","modified":"2026-02-04T04:28:48.180282Z","url":"https://osv.dev/vulnerability/GHSA-vvg7-8rmq-92g7"}],"assessments":[{"source":"OSV","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N","score":6.8}]}