GHSA-vfpx-q664-h93mhigh8.2
Auth0 WordPress Plugin has Insufficient Entropy in Cookie Encryption
No CVE assignedCheck your stack
The advisory, in context
Impact
In applications built with the Auth0 PHP SDK, cookies are encrypted with insufficient entropy, which may result in threat actors brute-forcing the encryption key and forging session cookies.
Am I Affected?
Consumers are affected if their application meets the following preconditions:
- It is using the Auth0 WordPress Plugin, versions between 5.0.0-BETA0 and 5.5.0
- Auth0 WordPress plugin using the Auth0-PHP SDK versions between 8.0.0 to 8.18.0.
Resolution
Upgrade Auth0/wordpress to version 5.6.0 or greater.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
auth0/wordpress Packagist
Ecosystem versions
From 5.0.0-BETA0 before 5.6.0
Fixed in 5.6.0
10 explicitly affected versions
5.0.0, 5.0.0-BETA0, 5.0.0-BETA1, 5.0.1, 5.1.0, 5.2.0, 5.2.1, 5.3.0, 5.4.0, 5.5.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "5.0.0-BETA0"
},
{
"fixed": "5.6.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"5.0.0",
"5.0.0-BETA0",
"5.0.0-BETA1",
"5.0.1",
"5.1.0",
"5.2.0",
"5.2.1",
"5.3.0",
"5.4.0",
"5.5.0"
]
}