{"id":"GHSA-vfpx-q664-h93m","aliases":[],"title":"Auth0 WordPress Plugin has Insufficient Entropy in Cookie Encryption","description":"### Impact\nIn applications built with the Auth0 PHP SDK, cookies are encrypted with insufficient entropy, which may result in threat actors brute-forcing the encryption key and forging session cookies.\n\n### Am I Affected?\nConsumers are affected if their application meets the following preconditions:\n- It is using the Auth0 WordPress Plugin, versions between 5.0.0-BETA0 and 5.5.0\n- Auth0 WordPress plugin using the Auth0-PHP SDK versions between 8.0.0 to 8.18.0.\n\n### Resolution\nUpgrade Auth0/wordpress to version 5.6.0 or greater.","severity":"high","score":8.2,"published":"2026-04-03T03:43:13.000Z","modified":"2026-04-03T03:49:35.166Z","withdrawn":false,"knownExploited":false,"affected":[{"ecosystem":"Packagist","name":"auth0/wordpress","ranges":[{"events":[{"introduced":"5.0.0-BETA0"},{"fixed":"5.6.0"}],"type":"ECOSYSTEM"}],"versions":["5.0.0","5.0.0-BETA0","5.0.0-BETA1","5.0.1","5.1.0","5.2.0","5.2.1","5.3.0","5.4.0","5.5.0"],"fixed":["5.6.0"]}],"references":["https://github.com/auth0/wordpress/security/advisories/GHSA-vfpx-q664-h93m","https://github.com/auth0/wordpress"],"sources":[{"name":"OSV","id":"GHSA-vfpx-q664-h93m","modified":"2026-04-03T03:49:35.166346Z","url":"https://osv.dev/vulnerability/GHSA-vfpx-q664-h93m"}],"assessments":[{"source":"OSV","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:N","score":8.2}]}