GHSA-vcwc-6mr9-8m7cmedium6.1
Cross-site Scripting in phpmyadmin
The advisory, in context
An issue was discovered in phpMyAdmin 5.1 before 5.1.2. An attacker can inject malicious code into aspects of the setup script, which can allow XSS or HTML injection.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
phpmyadmin/phpmyadmin Packagist
Ecosystem versions
From 5.1.0 before 5.1.2
Fixed in 5.1.2
2 explicitly affected versions
5.1.0, 5.1.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "5.1.0"
},
{
"fixed": "5.1.2"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"5.1.0",
"5.1.1"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2022-23808
- https://github.com/phpmyadmin/phpmyadmin/commit/44eb12f15a562718bbe54c9a16af91ceea335d59
- https://github.com/phpmyadmin/phpmyadmin/commit/5118acce1dfcdb09cbc0f73927bf51c46feeaf38
- https://github.com/phpmyadmin/phpmyadmin
- https://infosecwriteups.com/exploit-cve-2022-23808-85041c6e5b97
- https://security.gentoo.org/glsa/202311-17
- https://www.phpmyadmin.net/security/PMASA-2022-2