GHSA-v6fp-h79x-9rqchigh8.8
phpMyAdmin CSRF vulnerability allowing arbitrary SQL execution
The advisory, in context
phpMyAdmin 4.8.0 before 4.8.0-1 has CSRF, allowing an attacker to execute arbitrary SQL statements, related to js/db_operations.js, js/tbl_operations.js, libraries/classes/Operations.php, and sql.php.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
phpmyadmin/phpmyadmin Packagist
Ecosystem versions
From 4.8 before 4.8.0.1
Fixed in 4.8.0.1
1 explicitly affected versions
4.8.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.8"
},
{
"fixed": "4.8.0.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"4.8.0"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2018-10188
- https://github.com/phpmyadmin/phpmyadmin/commit/c6dd6b56e236a3aff953cee4135ecaa67130e641
- https://github.com/phpmyadmin/composer
- https://www.exploit-db.com/exploits/44496
- https://www.phpmyadmin.net/security/PMASA-2018-2
- http://www.securityfocus.com/bid/103936
- http://www.securitytracker.com/id/1040752