GHSA-rv57-479x-x4qvcritical9.8
phpMyAdmin Code Injection vulnerability
The advisory, in context
phpMyAdmin 4.0.x before 4.0.10.16, 4.4.x before 4.4.15.7, and 4.6.x before 4.6.3 does not properly choose delimiters to prevent use of the preg_replace e (aka eval) modifier, which might allow remote attackers to execute arbitrary PHP code via a crafted string, as demonstrated by the table search-and-replace implementation.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
phpmyadmin/phpmyadmin Packagist
Ecosystem versions
From 4.0.10.0 before 4.0.10.16
Fixed in 4.0.10.16
9 explicitly affected versions
4.0.10.1, 4.0.10.2, 4.0.10.3, 4.0.10.4, 4.0.10.5, 4.0.10.6, 4.0.10.7, 4.0.10.8, 4.0.10.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.0.10.0"
},
{
"fixed": "4.0.10.16"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"4.0.10.1",
"4.0.10.2",
"4.0.10.3",
"4.0.10.4",
"4.0.10.5",
"4.0.10.6",
"4.0.10.7",
"4.0.10.8",
"4.0.10.9"
]
}phpmyadmin/phpmyadmin Packagist
Ecosystem versions
From 4.4.15.0 before 4.4.15.7
Fixed in 4.4.15.7
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.4.15.0"
},
{
"fixed": "4.4.15.7"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}phpmyadmin/phpmyadmin Packagist
Ecosystem versions
From 4.6.0 before 4.6.3
Fixed in 4.6.3
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.6.0"
},
{
"fixed": "4.6.3"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}References
- https://nvd.nist.gov/vuln/detail/CVE-2016-5734
- https://github.com/phpmyadmin/phpmyadmin/commit/1cc7466db3a05e95fe57a6702f41773e6829d54b
- https://github.com/phpmyadmin/phpmyadmin/commit/4bcc606225f15bac0b07780e74f667f6ac283da7
- https://github.com/phpmyadmin/phpmyadmin
- https://security.gentoo.org/glsa/201701-32
- https://web.archive.org/web/20200227223418/http://www.securityfocus.com/bid/91387
- https://www.exploit-db.com/exploits/40185
- https://www.phpmyadmin.net/security/PMASA-2016-27