{"id":"GHSA-rv57-479x-x4qv","aliases":["CVE-2016-5734"],"title":"phpMyAdmin Code Injection vulnerability","description":"phpMyAdmin 4.0.x before 4.0.10.16, 4.4.x before 4.4.15.7, and 4.6.x before 4.6.3 does not properly choose delimiters to prevent use of the preg_replace e (aka eval) modifier, which might allow remote attackers to execute arbitrary PHP code via a crafted string, as demonstrated by the table search-and-replace implementation.","severity":"critical","score":9.8,"published":"2022-05-17T02:37:29.000Z","modified":"2025-04-14T22:27:15.983Z","withdrawn":false,"knownExploited":false,"affected":[{"ecosystem":"Packagist","name":"phpmyadmin/phpmyadmin","ranges":[{"events":[{"introduced":"4.0.10.0"},{"fixed":"4.0.10.16"}],"type":"ECOSYSTEM"}],"versions":["4.0.10.1","4.0.10.2","4.0.10.3","4.0.10.4","4.0.10.5","4.0.10.6","4.0.10.7","4.0.10.8","4.0.10.9"],"fixed":["4.0.10.16"]},{"ecosystem":"Packagist","name":"phpmyadmin/phpmyadmin","ranges":[{"events":[{"introduced":"4.4.15.0"},{"fixed":"4.4.15.7"}],"type":"ECOSYSTEM"}],"versions":[],"fixed":["4.4.15.7"]},{"ecosystem":"Packagist","name":"phpmyadmin/phpmyadmin","ranges":[{"events":[{"introduced":"4.6.0"},{"fixed":"4.6.3"}],"type":"ECOSYSTEM"}],"versions":[],"fixed":["4.6.3"]}],"references":["https://nvd.nist.gov/vuln/detail/CVE-2016-5734","https://github.com/phpmyadmin/phpmyadmin/commit/1cc7466db3a05e95fe57a6702f41773e6829d54b","https://github.com/phpmyadmin/phpmyadmin/commit/4bcc606225f15bac0b07780e74f667f6ac283da7","https://github.com/phpmyadmin/phpmyadmin","https://security.gentoo.org/glsa/201701-32","https://web.archive.org/web/20200227223418/http://www.securityfocus.com/bid/91387","https://www.exploit-db.com/exploits/40185","https://www.phpmyadmin.net/security/PMASA-2016-27"],"sources":[{"name":"OSV","id":"GHSA-rv57-479x-x4qv","modified":"2025-04-14T22:27:15.983900Z","url":"https://osv.dev/vulnerability/GHSA-rv57-479x-x4qv"}],"assessments":[{"source":"OSV","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":9.8}]}