GHSA-qx76-c53f-5c7qmedium6.1
PHP League CommonMark vulnerable to Cross-Site Scripting (XSS)
The advisory, in context
Cross-site scripting (XSS) vulnerability in the PHP League CommonMark library versions 0.15.6 through 0.18.x before 0.18.1 allows remote attackers to insert unsafe URLs into HTML (even if allow_unsafe_links is false) via a newline character (e.g., writing javascript as javascri%0apt).
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
league/commonmark Packagist
Ecosystem versions
From 0.15.6 before 0.18.1
Fixed in 0.18.1
10 explicitly affected versions
0.15.6, 0.15.7, 0.16.0, 0.17.0, 0.17.1, 0.17.2, 0.17.3, 0.17.4, 0.17.5, 0.18.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0.15.6"
},
{
"fixed": "0.18.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"0.15.6",
"0.15.7",
"0.16.0",
"0.17.0",
"0.17.1",
"0.17.2",
"0.17.3",
"0.17.4",
"0.17.5",
"0.18.0"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2018-20583
- https://github.com/thephpleague/commonmark/issues/337
- https://commonmark.thephpleague.com/changelog
- https://github.com/FriendsOfPHP/security-advisories/blob/master/league/commonmark/CVE-2018-20583.yaml
- https://github.com/thephpleague/commonmark
- https://github.com/thephpleague/commonmark/releases/tag/0.18.1