{"id":"GHSA-qx76-c53f-5c7q","aliases":["CVE-2018-20583"],"title":"PHP League CommonMark vulnerable to Cross-Site Scripting (XSS)","description":"Cross-site scripting (XSS) vulnerability in the PHP League CommonMark library versions 0.15.6 through 0.18.x before 0.18.1 allows remote attackers to insert unsafe URLs into HTML (even if allow_unsafe_links is false) via a newline character (e.g., writing javascript as javascri%0apt).","severity":"medium","score":6.1,"published":"2022-05-14T01:40:50.000Z","modified":"2024-02-16T08:16:43.743Z","withdrawn":false,"knownExploited":false,"affected":[{"ecosystem":"Packagist","name":"league/commonmark","ranges":[{"events":[{"introduced":"0.15.6"},{"fixed":"0.18.1"}],"type":"ECOSYSTEM"}],"versions":["0.15.6","0.15.7","0.16.0","0.17.0","0.17.1","0.17.2","0.17.3","0.17.4","0.17.5","0.18.0"],"fixed":["0.18.1"]}],"references":["https://nvd.nist.gov/vuln/detail/CVE-2018-20583","https://github.com/thephpleague/commonmark/issues/337","https://commonmark.thephpleague.com/changelog","https://github.com/FriendsOfPHP/security-advisories/blob/master/league/commonmark/CVE-2018-20583.yaml","https://github.com/thephpleague/commonmark","https://github.com/thephpleague/commonmark/releases/tag/0.18.1"],"sources":[{"name":"OSV","id":"GHSA-qx76-c53f-5c7q","modified":"2024-02-16T08:16:43.743975Z","url":"https://osv.dev/vulnerability/GHSA-qx76-c53f-5c7q"}],"assessments":[{"source":"OSV","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","score":6.1}]}