GHSA-qwvp-268g-jjm8medium
Data Leakage Vulnerability in livewire/livewire
No CVE assignedCheck your stack
The advisory, in context
livewire/livewire versions greater than 2.2.4 and less than 2.2.6 are affected by a data leakage vulnerability. The $this->validate() method, which is expected to return only the validated dataset, was returning all properties of the Livewire component. This regression introduced a security risk, allowing unvalidated data to be exposed, which could lead to unexpected behavior and potential security issues.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
livewire/livewire Packagist
Ecosystem versions
From 2.2.5 before 2.2.6
Fixed in 2.2.6
1 explicitly affected versions
v2.2.5
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.2.5"
},
{
"fixed": "2.2.6"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v2.2.5"
]
}