{"id":"GHSA-qwvp-268g-jjm8","aliases":[],"title":"Data Leakage Vulnerability in livewire/livewire","description":"livewire/livewire versions greater than 2.2.4 and less than 2.2.6 are affected by a data leakage vulnerability. The `$this->validate()` method, which is expected to return only the validated dataset, was returning all properties of the Livewire component. This regression introduced a security risk, allowing unvalidated data to be exposed, which could lead to unexpected behavior and potential security issues.\n\n","severity":"medium","score":null,"published":"2024-05-15T22:28:49.000Z","modified":"2024-11-29T05:28:26.022Z","withdrawn":false,"knownExploited":false,"affected":[{"ecosystem":"Packagist","name":"livewire/livewire","ranges":[{"events":[{"introduced":"2.2.5"},{"fixed":"2.2.6"}],"type":"ECOSYSTEM"}],"versions":["v2.2.5"],"fixed":["2.2.6"]}],"references":["https://github.com/livewire/livewire/commit/6929f5882138a98187c196ce66cc689712c000af","https://github.com/FriendsOfPHP/security-advisories/blob/master/livewire/livewire/2020-09-22-1.yaml","https://github.com/livewire/livewire","https://github.com/livewire/livewire/releases/tag/v2.2.6"],"sources":[{"name":"OSV","id":"GHSA-qwvp-268g-jjm8","modified":"2024-11-29T05:28:26.022746Z","url":"https://osv.dev/vulnerability/GHSA-qwvp-268g-jjm8"}],"assessments":[]}