GHSA-pm77-c4q7-3fwjmedium5.9
Improper Certificate Validation in Heartland & Global Payments PHP SDK
The advisory, in context
Gateways/Gateway.php in Heartland & Global Payments PHP SDK before 2.0.0 does not enforce SSL certificate validations.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
globalpayments/php-sdk Packagist
Ecosystem versions
Earlier releases before 2.0.0
Fixed in 2.0.0
13 explicitly affected versions
1.0.0, 1.1.0, 1.1.1, 1.1.2, 1.1.3, 1.2.0, 1.2.1, 1.2.2, 1.2.3, 1.3.0, 1.3.1, 1.3.2, 1.3.3
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "2.0.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.0.0",
"1.1.0",
"1.1.1",
"1.1.2",
"1.1.3",
"1.2.0",
"1.2.1",
"1.2.2",
"1.2.3",
"1.3.0",
"1.3.1",
"1.3.2",
"1.3.3"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2019-20455
- https://github.com/globalpayments/php-sdk/pull/8
- https://github.com/globalpayments/php-sdk/pull/8/commits/c86e18f28c5eba0d6ede7d557756d978ea83d3c9
- https://github.com/globalpayments/php-sdk
- https://github.com/globalpayments/php-sdk/compare/1.3.3...2.0.0
- https://github.com/globalpayments/php-sdk/releases/tag/2.0.0
- https://winterdragon.ca/global-payments-vulnerability