{"id":"GHSA-pm77-c4q7-3fwj","aliases":["CVE-2019-20455"],"title":"Improper Certificate Validation in Heartland & Global Payments PHP SDK","description":"Gateways/Gateway.php in Heartland & Global Payments PHP SDK before 2.0.0 does not enforce SSL certificate validations.","severity":"medium","score":5.9,"published":"2021-10-12T16:31:12.000Z","modified":"2024-02-17T05:26:24.182Z","withdrawn":false,"knownExploited":false,"affected":[{"ecosystem":"Packagist","name":"globalpayments/php-sdk","ranges":[{"events":[{"introduced":"0"},{"fixed":"2.0.0"}],"type":"ECOSYSTEM"}],"versions":["1.0.0","1.1.0","1.1.1","1.1.2","1.1.3","1.2.0","1.2.1","1.2.2","1.2.3","1.3.0","1.3.1","1.3.2","1.3.3"],"fixed":["2.0.0"]}],"references":["https://nvd.nist.gov/vuln/detail/CVE-2019-20455","https://github.com/globalpayments/php-sdk/pull/8","https://github.com/globalpayments/php-sdk/pull/8/commits/c86e18f28c5eba0d6ede7d557756d978ea83d3c9","https://github.com/globalpayments/php-sdk","https://github.com/globalpayments/php-sdk/compare/1.3.3...2.0.0","https://github.com/globalpayments/php-sdk/releases/tag/2.0.0","https://winterdragon.ca/global-payments-vulnerability"],"sources":[{"name":"OSV","id":"GHSA-pm77-c4q7-3fwj","modified":"2024-02-17T05:26:24.182590Z","url":"https://osv.dev/vulnerability/GHSA-pm77-c4q7-3fwj"}],"assessments":[{"source":"OSV","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N","score":5.9}]}