GHSA-p632-5w74-x8xxlow
phpMyAdmin Cross-site scripting (XSS) vulnerability via pageNumber value
The advisory, in context
Cross-site scripting (XSS) vulnerability in libraries/schema/Export_Relation_Schema.class.php in phpMyAdmin 3.5.x before 3.5.8.2 and 4.0.x before 4.0.4.2 allows remote authenticated users to inject arbitrary web script or HTML via a crafted pageNumber value to schema_export.php.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
phpmyadmin/phpmyadmin Packagist
Ecosystem versions
From 3.5 before 3.5.8.2
Fixed in 3.5.8.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.5"
},
{
"fixed": "3.5.8.2"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}phpmyadmin/phpmyadmin Packagist
Ecosystem versions
From 4.0 before 4.0.4.2
Fixed in 4.0.4.2
6 explicitly affected versions
4.0.0, 4.0.1, 4.0.2, 4.0.3, 4.0.4, 4.0.4.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.0"
},
{
"fixed": "4.0.4.2"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"4.0.0",
"4.0.1",
"4.0.2",
"4.0.3",
"4.0.4",
"4.0.4.1"
]
}