Magento 2 Community Edition XSS Vulnerability
Impact
A stored cross-site scripting (XSS) vulnerability exists in in Magento 1 prior to 1.9.4.3 and 1.14.4.3, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user with access to the wysiwyg editor can abuse the blockDirective() function and inject malicious javascript in the cache of the admin dashboard.
Source excerpt · OSVAffected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
| Affected range | Recorded fix |
|---|---|
| From 2.2.0 before 2.2.10Ecosystem versions | 2.2.10 |
| From 2.3 before 2.3.2-p2Ecosystem versions | 2.3.2-p2 |
Version evidence: OSV · GHSA-jjmg-xmq2-g6ff
View original version evidence (13 explicit versions)
Original source description
A stored cross-site scripting (XSS) vulnerability exists in in Magento 1 prior to 1.9.4.3 and 1.14.4.3, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user with access to the wysiwyg editor can abuse the blockDirective() function and inject malicious javascript in the cache of the admin dashboard.
As per the Magento Release 2.3.3, if you have already implemented the pre-release version of this patch (2.3.2-p1), it is highly recommended to promptly upgrade to 2.3.2-p2.
References
- Security advisory nvd.nist.gov/vuln/detail/CVE-2019-8152
- Security advisory github.com/FriendsOfPHP/security-advisories/blob/master/magento/magento1ce/CVE-2019-8152.yaml
- Security advisory github.com/FriendsOfPHP/security-advisories/blob/master/magento/magento1ee/CVE-2019-8152.yaml
- Security advisory github.com/FriendsOfPHP/security-advisories/blob/master/magento/product-community-edition/CVE-2019-8152.yaml
- Source reference github.com/magento/magento2
- Security advisory magento.com/security/patches/magento-2.3.3-and-2.2.10-security-update
- Security advisory web.archive.org/web/20211209030216/https://magento.com/security/patches/supee-11219