{"id":"GHSA-jjmg-xmq2-g6ff","aliases":["CVE-2019-8152"],"title":"Magento 2 Community Edition XSS Vulnerability","titleSource":"OSV","descriptionSource":"OSV","declaredSeverity":"MODERATE","description":"A stored cross-site scripting (XSS) vulnerability exists in in Magento 1 prior to 1.9.4.3 and 1.14.4.3, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user with access to the wysiwyg editor can abuse the `blockDirective()` function and inject malicious javascript in the cache of the admin dashboard.\n\nAs per [the Magento Release 2.3.3](https://web.archive.org/web/20201126132230/https://devdocs.magento.com/guides/v2.3/release-notes/release-notes-2-3-3-commerce.html#new-security-only-patch-available), if you have already implemented the pre-release version of this patch (2.3.2-p1), it is highly recommended to promptly upgrade to 2.3.2-p2.","severity":"medium","score":4.8,"published":"2022-05-24T17:00:28.000Z","modified":"2024-02-16T08:19:24.041Z","withdrawn":false,"knownExploited":false,"affected":[{"ecosystem":"Packagist","name":"magento/community-edition","sources":[{"name":"OSV · GHSA-jjmg-xmq2-g6ff","url":"https://osv.dev/vulnerability/GHSA-jjmg-xmq2-g6ff"}],"ranges":[{"events":[{"introduced":"2.2.0"},{"fixed":"2.2.10"}],"type":"ECOSYSTEM"}],"versions":["2.2.0","2.2.1","2.2.2","2.2.3","2.2.4","2.2.5","2.2.6","2.2.7","2.2.8","2.2.9"],"fixed":["2.2.10"]},{"ecosystem":"Packagist","name":"magento/community-edition","sources":[{"name":"OSV · GHSA-jjmg-xmq2-g6ff","url":"https://osv.dev/vulnerability/GHSA-jjmg-xmq2-g6ff"}],"ranges":[{"events":[{"introduced":"2.3"},{"fixed":"2.3.2-p2"}],"type":"ECOSYSTEM"}],"versions":["2.3.0","2.3.1","2.3.2"],"fixed":["2.3.2-p2"]}],"sourceAffected":[],"references":["https://nvd.nist.gov/vuln/detail/CVE-2019-8152","https://github.com/FriendsOfPHP/security-advisories/blob/master/magento/magento1ce/CVE-2019-8152.yaml","https://github.com/FriendsOfPHP/security-advisories/blob/master/magento/magento1ee/CVE-2019-8152.yaml","https://github.com/FriendsOfPHP/security-advisories/blob/master/magento/product-community-edition/CVE-2019-8152.yaml","https://github.com/magento/magento2","https://magento.com/security/patches/magento-2.3.3-and-2.2.10-security-update","https://web.archive.org/web/20211209030216/https://magento.com/security/patches/supee-11219"],"sources":[{"name":"OSV","id":"GHSA-jjmg-xmq2-g6ff","modified":"2024-02-16T08:19:24.041565Z","url":"https://osv.dev/vulnerability/GHSA-jjmg-xmq2-g6ff"}],"assessments":[{"source":"OSV","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N","score":4.8}],"products":[],"remediation":[],"kev":{"status":"not-listed","checkedAt":"2026-10-28T22:45:32.681Z"},"coverage":[{"source":"NVD","status":"not-checked"},{"source":"GHSA","status":"not-checked"},{"source":"EUVD","status":"not-checked"},{"source":"EPSS","status":"not-checked"}],"evidence":[]}