GHSA-hhfw-xxhm-pf32medium6.1
ADOdb Cross-site scripting vulnerability in old test script
The advisory, in context
Cross-site scripting vulnerability in ADOdb versions prior to 5.20.6 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
adodb/adodb-php Packagist
Ecosystem versions
Earlier releases before 5.20.6
Fixed in 5.20.6
7 explicitly affected versions
v5.19, v5.20.0, v5.20.1, v5.20.2, v5.20.3, v5.20.4, v5.20.5
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "5.20.6"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v5.19",
"v5.20.0",
"v5.20.1",
"v5.20.2",
"v5.20.3",
"v5.20.4",
"v5.20.5"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2016-4855
- https://github.com/ADOdb/ADOdb/issues/274
- https://github.com/ADOdb/ADOdb/commit/ecb93d8c1fd3bbde62aca9c3a13c32f077da2da8
- https://github.com/ADOdb/ADOdb
- https://github.com/FriendsOfPHP/security-advisories/blob/master/adodb/adodb-php/CVE-2016-4855.yaml
- https://security.gentoo.org/glsa/201701-59
- http://jvn.jp/en/jp/JVN48237713/index.html
- http://www.securityfocus.com/bid/92753