GHSA-ghc5-95c2-vwcvhigh8.2
Auth0 Symfony SDK has Insufficient Entropy in Cookie Encryption
No CVE assignedCheck your stack
The advisory, in context
Impact
In applications built with the Auth0 PHP SDK, cookies are encrypted with insufficient entropy, which may result in threat actors brute-forcing the encryption key and forging session cookies.
Am I Affected?
Consumers are affected if their application meets the following preconditions:
- It uses the Auth0 Symfony SDK, versions between 5.0.0 and 5.7.0
- Auth0 Symfony SDK using the Auth0-PHP SDK versions between 8.0.0 to 8.18.0.
Resolution
Upgrade Auth0/symfony-auth0 to version 5.8.0 or greater.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
auth0/symfony Packagist
Ecosystem versions
From 5.0.0 before 5.8.0
Fixed in 5.8.0
13 explicitly affected versions
5.0.0, 5.1.0, 5.2.0, 5.2.1, 5.2.2, 5.2.3, 5.3.0, 5.3.1, 5.4.0, 5.4.1, 5.5.0, 5.6.0, 5.7.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "5.0.0"
},
{
"fixed": "5.8.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"5.0.0",
"5.1.0",
"5.2.0",
"5.2.1",
"5.2.2",
"5.2.3",
"5.3.0",
"5.3.1",
"5.4.0",
"5.4.1",
"5.5.0",
"5.6.0",
"5.7.0"
]
}