{"id":"GHSA-ghc5-95c2-vwcv","aliases":[],"title":"Auth0 Symfony SDK has Insufficient Entropy in Cookie Encryption","description":"### Impact\nIn applications built with the Auth0 PHP SDK, cookies are encrypted with insufficient entropy, which may result in threat actors brute-forcing the encryption key and forging session cookies.\n\n### Am I Affected?\nConsumers are affected if their application meets the following preconditions:\n- It uses the Auth0 Symfony SDK, versions between 5.0.0 and 5.7.0\n- Auth0 Symfony SDK using the Auth0-PHP SDK versions between 8.0.0 to 8.18.0.\n\n### Resolution\nUpgrade Auth0/symfony-auth0 to version 5.8.0 or greater.","severity":"high","score":8.2,"published":"2026-04-03T03:44:13.000Z","modified":"2026-04-03T04:05:14.160Z","withdrawn":false,"knownExploited":false,"affected":[{"ecosystem":"Packagist","name":"auth0/symfony","ranges":[{"events":[{"introduced":"5.0.0"},{"fixed":"5.8.0"}],"type":"ECOSYSTEM"}],"versions":["5.0.0","5.1.0","5.2.0","5.2.1","5.2.2","5.2.3","5.3.0","5.3.1","5.4.0","5.4.1","5.5.0","5.6.0","5.7.0"],"fixed":["5.8.0"]}],"references":["https://github.com/auth0/symfony/security/advisories/GHSA-ghc5-95c2-vwcv","https://github.com/auth0/symfony"],"sources":[{"name":"OSV","id":"GHSA-ghc5-95c2-vwcv","modified":"2026-04-03T04:05:14.160135Z","url":"https://osv.dev/vulnerability/GHSA-ghc5-95c2-vwcv"}],"assessments":[{"source":"OSV","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:N","score":8.2}]}