GHSA-9m72-pw47-292whigh7.2
Joomla RCE Vulnerability
The advisory, in context
An issue was discovered in Joomla! before 3.8.13. com_joomlaupdate allows the execution of arbitrary code. The default ACL config enabled the ability of Administrator-level users to access com_joomlaupdate and trigger code execution.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
joomla/framework Packagist
Ecosystem versions
From 2.5.4 before 3.8.13
Fixed in 3.8.13
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.5.4"
},
{
"fixed": "3.8.13"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}References
- https://nvd.nist.gov/vuln/detail/CVE-2018-17856
- https://developer.joomla.org/security-centre/752-20181002-core-inadequate-default-access-level-for-com-joomlaupdate.html
- https://github.com/joomla/joomla-cms
- https://web.archive.org/web/20210124211736/http://www.securityfocus.com/bid/105559
- https://web.archive.org/web/20211208125303/http://www.securitytracker.com/id/1041914