GHSA-8c6q-26w6-qwhgmedium6.3
Easy!Appointments Improper Access Control vulnerability
The advisory, in context
Easy!Appointments 1.4.3 and prior has an Improper Access Control vulnerability. This issue is patched at commit b37b46019553089db4f22eb2fe998bca84b2cb64 and anticipated to be part of version 1.5.0.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
alextselegidis/easyappointments Packagist
Ecosystem versions
Earlier releases before 1.5.0
Fixed in 1.5.0
23 explicitly affected versions
1.1.0, 1.1.0-beta.1, 1.1.0-beta.2, 1.1.1, 1.2.0, 1.2.0-alpha.1, 1.2.0-beta.1, 1.2.1, 1.3.0, 1.3.0-alpha.1, 1.3.0-beta.1, 1.3.0-beta.2, 1.3.1, 1.3.1-beta.1, 1.3.2, 1.3.2-beta.1, 1.4.0, 1.4.0-beta.1, 1.4.1, 1.4.2, 1.4.2-beta.1, 1.4.3, 1.4.3-beta.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "1.5.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.1.0",
"1.1.0-beta.1",
"1.1.0-beta.2",
"1.1.1",
"1.2.0",
"1.2.0-alpha.1",
"1.2.0-beta.1",
"1.2.1",
"1.3.0",
"1.3.0-alpha.1",
"1.3.0-beta.1",
"1.3.0-beta.2",
"1.3.1",
"1.3.1-beta.1",
"1.3.2",
"1.3.2-beta.1",
"1.4.0",
"1.4.0-beta.1",
"1.4.1",
"1.4.2",
"1.4.2-beta.1",
"1.4.3",
"1.4.3-beta.1"
]
}