GHSA-7r2v-8wxr-3ch5medium6.1
Yii does not prevent XSS in scenarios where fallback error renderer is used
The advisory, in context
Impact
Affected versions of yiisoft/yii are vulnerable to Reflected XSS in specific scenarios where the fallback error renderer is used.
Patches
Upgrade yiisoft/yii to version 1.1.31 or higher.
References
If you have any questions or comments about this advisory, contact us through security form.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
yiisoft/yii Packagist
Ecosystem versions
Earlier releases before 1.1.31
Fixed in 1.1.31
18 explicitly affected versions
1.1.14, 1.1.14-rc, 1.1.15, 1.1.16, 1.1.17, 1.1.18, 1.1.19, 1.1.20, 1.1.21, 1.1.22, 1.1.23, 1.1.24, 1.1.25, 1.1.26, 1.1.27, 1.1.28, 1.1.29, 1.1.30
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "1.1.31"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.1.14",
"1.1.14-rc",
"1.1.15",
"1.1.16",
"1.1.17",
"1.1.18",
"1.1.19",
"1.1.20",
"1.1.21",
"1.1.22",
"1.1.23",
"1.1.24",
"1.1.25",
"1.1.26",
"1.1.27",
"1.1.28",
"1.1.29",
"1.1.30"
]
}