{"id":"GHSA-7r2v-8wxr-3ch5","aliases":["CVE-2025-32027"],"title":"Yii does not prevent XSS in scenarios where fallback error renderer is used","description":"### Impact\nAffected versions of yiisoft/yii are vulnerable to Reflected XSS in specific scenarios where the fallback error renderer is used.\n\n### Patches\nUpgrade yiisoft/yii to version 1.1.31 or higher.\n\n### References\n- [Git commit](https://github.com/yiisoft/yii/commit/d386d737861c9014269b7ed8c36c65eadb387368)\n\nIf you have any questions or comments about this advisory, [contact us through security form](https://www.yiiframework.com/security).","severity":"medium","score":6.1,"published":"2025-04-11T14:05:18.000Z","modified":"2025-04-11T14:43:22.403Z","withdrawn":false,"knownExploited":false,"affected":[{"ecosystem":"Packagist","name":"yiisoft/yii","ranges":[{"events":[{"introduced":"0"},{"fixed":"1.1.31"}],"type":"ECOSYSTEM"}],"versions":["1.1.14","1.1.14-rc","1.1.15","1.1.16","1.1.17","1.1.18","1.1.19","1.1.20","1.1.21","1.1.22","1.1.23","1.1.24","1.1.25","1.1.26","1.1.27","1.1.28","1.1.29","1.1.30"],"fixed":["1.1.31"]}],"references":["https://github.com/yiisoft/yii/security/advisories/GHSA-7r2v-8wxr-3ch5","https://nvd.nist.gov/vuln/detail/CVE-2025-32027","https://github.com/yiisoft/yii/commit/d386d737861c9014269b7ed8c36c65eadb387368","https://github.com/yiisoft/yii"],"sources":[{"name":"OSV","id":"GHSA-7r2v-8wxr-3ch5","modified":"2025-04-11T14:43:22.403665Z","url":"https://osv.dev/vulnerability/GHSA-7r2v-8wxr-3ch5"}],"assessments":[{"source":"OSV","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","score":6.1}]}