GHSA-7j4m-f87g-5r9rmedium5.4
Complianz WordPress plugin vulnerable to cross-site scripting
The advisory, in context
The Complianz Premium WordPress plugin before 6.4.2 did not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
really-simple-plugins/complianz-gdpr Packagist
Ecosystem versions
Earlier releases before 6.4.2
Fixed in 6.4.2
17 explicitly affected versions
v6.1.2, v6.1.3, v6.1.5, v6.1.6, v6.1.6.1, v6.2.0, v6.2.4, v6.3.0, v6.3.1, v6.3.2, v6.3.2.1, v6.3.3, v6.3.4, v6.3.6, v6.3.6.1, v6.3.9, v6.4.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "6.4.2"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v6.1.2",
"v6.1.3",
"v6.1.5",
"v6.1.6",
"v6.1.6.1",
"v6.2.0",
"v6.2.4",
"v6.3.0",
"v6.3.1",
"v6.3.2",
"v6.3.2.1",
"v6.3.3",
"v6.3.4",
"v6.3.6",
"v6.3.6.1",
"v6.3.9",
"v6.4.1"
]
}