{"id":"GHSA-7j4m-f87g-5r9r","aliases":["CVE-2023-1069"],"title":"Complianz WordPress plugin vulnerable to cross-site scripting","description":"The Complianz Premium WordPress plugin before 6.4.2 did not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.","severity":"medium","score":5.4,"published":"2023-03-27T18:30:26.000Z","modified":"2024-02-22T05:31:45.064Z","withdrawn":false,"knownExploited":false,"affected":[{"ecosystem":"Packagist","name":"really-simple-plugins/complianz-gdpr","ranges":[{"events":[{"introduced":"0"},{"fixed":"6.4.2"}],"type":"ECOSYSTEM"}],"versions":["v6.1.2","v6.1.3","v6.1.5","v6.1.6","v6.1.6.1","v6.2.0","v6.2.4","v6.3.0","v6.3.1","v6.3.2","v6.3.2.1","v6.3.3","v6.3.4","v6.3.6","v6.3.6.1","v6.3.9","v6.4.1"],"fixed":["6.4.2"]}],"references":["https://nvd.nist.gov/vuln/detail/CVE-2023-1069","https://github.com/Really-Simple-Plugins/complianz-gdpr/commit/e6c2c386cadb78f8cdcded1b000cbd38bd9ff043","https://wpscan.com/vulnerability/caacc50c-822e-46e9-bc0b-681349fd0dda"],"sources":[{"name":"OSV","id":"GHSA-7j4m-f87g-5r9r","modified":"2024-02-22T05:31:45.064288Z","url":"https://osv.dev/vulnerability/GHSA-7j4m-f87g-5r9r"}],"assessments":[{"source":"OSV","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","score":5.4}]}