GIVE YOUR AGENT THE EVIDENCE

Set up in your agent.

One prompt to get started. Paste it into your coding agent to connect cve.new through MCP and bring vulnerability context into your workflow.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GIVE YOUR AGENT THE EVIDENCE

Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GHSA-769f-539v-f5jghigh

PrestaShop gamification module ZIP archives were vulnerable from CVE-2017-9841

No CVE assignedCheck your stack

The advisory, in context

Impact

We have identified that some gamification module ZIP archives have been built with phpunit dev dependencies. PHPUnit contains a php script that would allow, on a webserver, an attacker to perform a RCE.

This vulnerability impacts

  • phpunit before 4.8.28 and 5.x before 5.6.3 as reported in CVE-2017-9841
  • phpunit >= 5.63 before 7.5.19 and 8.5.1 (this is a newly found vulnerability that is currently being submitted as a CVE after disclosure was provided to phpunit maintainers)

You can read PrestaShop official statement about this vulnerability here.

Patches

In the security patch, we look for the unwanted vendor/phpunit folder and remove it if we find it. This allows users to fix the security issue when upgrading.

Workarounds

Users can also simply remove the unwanted vendor/phpunit folder.

References

https://nvd.nist.gov/vuln/detail/CVE-2017-9841

For more information

If you have any questions or comments about this advisory, email us at security@prestashop.com

Affected packages

Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.

Ecosystem versions

Earlier releases before 2.3.2

Fixed in 2.3.2

14 explicitly affected versions

v1.11.0, v1.12.1, v1.12.2, v1.12.3, v1.13.0, v2.0.0, v2.0.1, v2.0.2, v2.0.3, v2.1.0, v2.2.0, v2.2.1, v2.3.0, v2.3.1

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "0"
        },
        {
          "fixed": "2.3.2"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "v1.11.0",
    "v1.12.1",
    "v1.12.2",
    "v1.12.3",
    "v1.13.0",
    "v2.0.0",
    "v2.0.1",
    "v2.0.2",
    "v2.0.3",
    "v2.1.0",
    "v2.2.0",
    "v2.2.1",
    "v2.3.0",
    "v2.3.1"
  ]
}

References