{"id":"GHSA-769f-539v-f5jg","aliases":[],"title":"PrestaShop gamification module ZIP archives were vulnerable from CVE-2017-9841","description":"### Impact\n\nWe have identified that some gamification module ZIP archives have been built with phpunit dev dependencies. PHPUnit contains a php script that would allow, on a webserver, an attacker to perform a RCE.\n\nThis vulnerability impacts\n- phpunit before 4.8.28 and 5.x before 5.6.3 as reported in [CVE-2017-9841](https://nvd.nist.gov/vuln/detail/CVE-2017-9841)\n- phpunit >= 5.63 before 7.5.19 and 8.5.1 (this is a newly found vulnerability that is currently being submitted as a CVE after disclosure was provided to phpunit maintainers)\n\nYou can read PrestaShop official statement about this vulnerability [here](https://build.prestashop.com/news/critical-security-vulnerability-in-prestashop-modules/).\n\n### Patches\n\nIn the [security patch](https://github.com/PrestaShop/gamification/releases/tag/v2.3.2), we look for the unwanted vendor/phpunit folder and remove it if we find it. This allows users to fix the security issue when upgrading.\n\n### Workarounds\nUsers can also simply remove the unwanted vendor/phpunit folder.\n\n### References\nhttps://nvd.nist.gov/vuln/detail/CVE-2017-9841\n\n### For more information\nIf you have any questions or comments about this advisory, email us at security@prestashop.com","severity":"high","score":null,"published":"2020-01-08T03:10:44.000Z","modified":"2024-12-02T05:44:41.184Z","withdrawn":false,"knownExploited":false,"affected":[{"ecosystem":"Packagist","name":"prestashop/gamification","ranges":[{"events":[{"introduced":"0"},{"fixed":"2.3.2"}],"type":"ECOSYSTEM"}],"versions":["v1.11.0","v1.12.1","v1.12.2","v1.12.3","v1.13.0","v2.0.0","v2.0.1","v2.0.2","v2.0.3","v2.1.0","v2.2.0","v2.2.1","v2.3.0","v2.3.1"],"fixed":["2.3.2"]}],"references":["https://github.com/PrestaShop/gamification/security/advisories/GHSA-769f-539v-f5jg","https://github.com/PrestaShop/gamification/commit/5044bda903a7ea9596c21faa2b9a42244763568c","https://build.prestashop.com/news/critical-security-vulnerability-in-prestashop-modules"],"sources":[{"name":"OSV","id":"GHSA-769f-539v-f5jg","modified":"2024-12-02T05:44:41.184099Z","url":"https://osv.dev/vulnerability/GHSA-769f-539v-f5jg"}],"assessments":[]}