GHSA-768m-5w34-2xf5high7.5
LTI 1.3 Tool Library's function used to generate random nonces not sufficiently cryptographically complex before v5.0
The advisory, in context
Impact
The function used to generate random nonces was not sufficiently cryptographically complex. As a result values may be predictable and tokens may be forgable.
Patches
Users should upgrade to version 5.0 immediately
Workarounds
None.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
packbackbooks/lti-1-3-php-library Packagist
Ecosystem versions
Earlier releases before 5.0
Fixed in 5.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "5.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}References
- https://github.com/packbackbooks/lti-1-3-php-library/security/advisories/GHSA-768m-5w34-2xf5
- https://nvd.nist.gov/vuln/detail/CVE-2022-31157
- https://github.com/packbackbooks/lti-1-3-php-library/commit/de19e8a0b28cdc7750fa3ca98471eeed26ba3e57
- https://github.com/packbackbooks/lti-1-3-php-library
- https://openid.net/specs/openid-connect-core-1_0.html#IDToken