{"id":"GHSA-768m-5w34-2xf5","aliases":["CVE-2022-31157"],"title":"LTI 1.3 Tool Library's function used to generate random nonces not sufficiently cryptographically complex before v5.0","description":"### Impact\n\nThe function used to generate random nonces was not sufficiently cryptographically complex. As a result values may be predictable and tokens may be forgable.\n\n### Patches\n\nUsers should upgrade to version 5.0 immediately\n\n### Workarounds\n\nNone.\n\n","severity":"high","score":7.5,"published":"2022-07-15T20:55:46.000Z","modified":"2023-11-08T04:09:28.038Z","withdrawn":false,"knownExploited":false,"affected":[{"ecosystem":"Packagist","name":"packbackbooks/lti-1-3-php-library","ranges":[{"events":[{"introduced":"0"},{"fixed":"5.0"}],"type":"ECOSYSTEM"}],"versions":[],"fixed":["5.0"]}],"references":["https://github.com/packbackbooks/lti-1-3-php-library/security/advisories/GHSA-768m-5w34-2xf5","https://nvd.nist.gov/vuln/detail/CVE-2022-31157","https://github.com/packbackbooks/lti-1-3-php-library/commit/de19e8a0b28cdc7750fa3ca98471eeed26ba3e57","https://github.com/packbackbooks/lti-1-3-php-library","https://openid.net/specs/openid-connect-core-1_0.html#IDToken"],"sources":[{"name":"OSV","id":"GHSA-768m-5w34-2xf5","modified":"2023-11-08T04:09:28.038385Z","url":"https://osv.dev/vulnerability/GHSA-768m-5w34-2xf5"}],"assessments":[{"source":"OSV","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","score":7.5}]}