GHSA-5fgv-cvr8-xg48low1.3
Moodle vulnerable to Cross-site Scripting
The advisory, in context
Multiple cross-site scripting (XSS) vulnerabilities in Moodle 1.8.x before 1.8.12 and 1.9.x before 1.9.8 allow remote attackers to inject arbitrary web script or HTML via vectors related to (1) the Login-As feature or (2) when the global search feature is enabled, unspecified global search forms in the Global Search Engine. NOTE: vector 1 might be resultant from a cross-site request forgery (CSRF) vulnerability.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
moodle/moodle Packagist
Ecosystem versions
From 1.8.0 before 1.8.12
Fixed in 1.8.12
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "1.8.0"
},
{
"fixed": "1.8.12"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}moodle/moodle Packagist
Ecosystem versions
From 1.9.0 before 1.9.8
Fixed in 1.9.8
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "1.9.0"
},
{
"fixed": "1.9.8"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}