{"id":"GHSA-5fgv-cvr8-xg48","aliases":["CVE-2010-1614"],"title":"Moodle vulnerable to Cross-site Scripting","description":"Multiple cross-site scripting (XSS) vulnerabilities in Moodle 1.8.x before 1.8.12 and 1.9.x before 1.9.8 allow remote attackers to inject arbitrary web script or HTML via vectors related to (1) the Login-As feature or (2) when the global search feature is enabled, unspecified global search forms in the Global Search Engine.  NOTE: vector 1 might be resultant from a cross-site request forgery (CSRF) vulnerability.","severity":"low","score":1.3,"published":"2022-05-13T01:13:08.000Z","modified":"2025-04-11T20:27:15.930Z","withdrawn":false,"knownExploited":false,"affected":[{"ecosystem":"Packagist","name":"moodle/moodle","ranges":[{"events":[{"introduced":"1.8.0"},{"fixed":"1.8.12"}],"type":"ECOSYSTEM"}],"versions":[],"fixed":["1.8.12"]},{"ecosystem":"Packagist","name":"moodle/moodle","ranges":[{"events":[{"introduced":"1.9.0"},{"fixed":"1.9.8"}],"type":"ECOSYSTEM"}],"versions":[],"fixed":["1.9.8"]}],"references":["https://nvd.nist.gov/vuln/detail/CVE-2010-1614","https://github.com/moodle/moodle","http://lists.opensuse.org/opensuse-security-announce/2010-05/msg00001.html","http://moodle.org/security"],"sources":[{"name":"OSV","id":"GHSA-5fgv-cvr8-xg48","modified":"2025-04-11T20:27:15.930450Z","url":"https://osv.dev/vulnerability/GHSA-5fgv-cvr8-xg48"}],"assessments":[{"source":"OSV","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:U","score":1.3}]}