GIVE YOUR AGENT THE EVIDENCE

Set up in your agent.

One prompt to get started. Paste it into your coding agent to connect cve.new through MCP and bring vulnerability context into your workflow.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GIVE YOUR AGENT THE EVIDENCE

Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

All vulnerabilities
GHSA-5868-g58j-vrj5critical9.8

phpMyAdmin Improper Privilege Management

Check your stack

The advisory, in context

An issue was discovered in libraries/common.inc.php in phpMyAdmin 4.0 before 4.0.10.20, 4.4.x, 4.6.x, and 4.7.0 prereleases. The restrictions caused by $cfg['Servers'][$i]['AllowNoPassword'] = false are bypassed under certain PHP versions (e.g., version 5). This can allow the login of users who have no password set even if the administrator has set $cfg['Servers'][$i]['AllowNoPassword'] to false (which is also the default). This occurs because some implementations of the PHP substr function return false when given '' as the first argument.

Affected packages

Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.

Ecosystem versions

From 4.0 before 4.0.10.20

Fixed in 4.0.10.20

22 explicitly affected versions

4.0.0, 4.0.1, 4.0.10, 4.0.10.1, 4.0.10.2, 4.0.10.3, 4.0.10.4, 4.0.10.5, 4.0.10.6, 4.0.10.7, 4.0.10.8, 4.0.10.9, 4.0.2, 4.0.3, 4.0.4, 4.0.4.1, 4.0.4.2, 4.0.5, 4.0.6, 4.0.7, 4.0.8, 4.0.9

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "4.0"
        },
        {
          "fixed": "4.0.10.20"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "4.0.0",
    "4.0.1",
    "4.0.10",
    "4.0.10.1",
    "4.0.10.2",
    "4.0.10.3",
    "4.0.10.4",
    "4.0.10.5",
    "4.0.10.6",
    "4.0.10.7",
    "4.0.10.8",
    "4.0.10.9",
    "4.0.2",
    "4.0.3",
    "4.0.4",
    "4.0.4.1",
    "4.0.4.2",
    "4.0.5",
    "4.0.6",
    "4.0.7",
    "4.0.8",
    "4.0.9"
  ]
}
Ecosystem versions

From 4.7.0-beta1 before 4.7.0

Fixed in 4.7.0

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "4.7.0-beta1"
        },
        {
          "fixed": "4.7.0"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": []
}
Ecosystem versions

From 4.4.0 through 4.4.15.10 (inclusive)

No fix recorded for this interval.

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "4.4.0"
        },
        {
          "last_affected": "4.4.15.10"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": []
}
Ecosystem versions

From 4.6.0 through 4.6.6 (inclusive)

No fix recorded for this interval.

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "4.6.0"
        },
        {
          "last_affected": "4.6.6"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": []
}

References