{"id":"GHSA-5868-g58j-vrj5","aliases":["CVE-2017-18264"],"title":"phpMyAdmin Improper Privilege Management","description":"An issue was discovered in libraries/common.inc.php in phpMyAdmin 4.0 before 4.0.10.20, 4.4.x, 4.6.x, and 4.7.0 prereleases. The restrictions caused by $cfg['Servers'][$i]['AllowNoPassword'] = false are bypassed under certain PHP versions (e.g., version 5). This can allow the login of users who have no password set even if the administrator has set $cfg['Servers'][$i]['AllowNoPassword'] to false (which is also the default). This occurs because some implementations of the PHP substr function return false when given '' as the first argument.","severity":"critical","score":9.8,"published":"2022-05-13T01:44:38.000Z","modified":"2024-04-24T18:42:01.594Z","withdrawn":false,"knownExploited":false,"affected":[{"ecosystem":"Packagist","name":"phpmyadmin/phpmyadmin","ranges":[{"events":[{"introduced":"4.0"},{"fixed":"4.0.10.20"}],"type":"ECOSYSTEM"}],"versions":["4.0.0","4.0.1","4.0.10","4.0.10.1","4.0.10.2","4.0.10.3","4.0.10.4","4.0.10.5","4.0.10.6","4.0.10.7","4.0.10.8","4.0.10.9","4.0.2","4.0.3","4.0.4","4.0.4.1","4.0.4.2","4.0.5","4.0.6","4.0.7","4.0.8","4.0.9"],"fixed":["4.0.10.20"]},{"ecosystem":"Packagist","name":"phpmyadmin/phpmyadmin","ranges":[{"events":[{"introduced":"4.7.0-beta1"},{"fixed":"4.7.0"}],"type":"ECOSYSTEM"}],"versions":[],"fixed":["4.7.0"]},{"ecosystem":"Packagist","name":"phpmyadmin/phpmyadmin","ranges":[{"events":[{"introduced":"4.4.0"},{"last_affected":"4.4.15.10"}],"type":"ECOSYSTEM"}],"versions":[],"fixed":[]},{"ecosystem":"Packagist","name":"phpmyadmin/phpmyadmin","ranges":[{"events":[{"introduced":"4.6.0"},{"last_affected":"4.6.6"}],"type":"ECOSYSTEM"}],"versions":[],"fixed":[]}],"references":["https://nvd.nist.gov/vuln/detail/CVE-2017-18264","https://github.com/phpmyadmin/composer","https://lists.debian.org/debian-lts-announce/2018/07/msg00006.html","https://www.phpmyadmin.net/security/PMASA-2017-8","http://www.securityfocus.com/bid/97211"],"sources":[{"name":"OSV","id":"GHSA-5868-g58j-vrj5","modified":"2024-04-24T18:42:01.594746Z","url":"https://osv.dev/vulnerability/GHSA-5868-g58j-vrj5"}],"assessments":[{"source":"OSV","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":9.8}]}