GHSA-3p87-w3c5-27gflow
phpMyAdmin Multiple XSS Vulnerabilities After Inline Editing and Save
The advisory, in context
Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 3.4.x before 3.4.5 allow remote authenticated users to inject arbitrary web script or HTML via a crafted row that triggers an improperly constructed confirmation message after inline-editing and save operations, related to (1) js/functions.js and (2) js/tbl_structure.js.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
phpmyadmin/phpmyadmin Packagist
Ecosystem versions
From 3.4.0 before 3.4.5
Fixed in 3.4.5
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.4.0"
},
{
"fixed": "3.4.5"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}References
- https://nvd.nist.gov/vuln/detail/CVE-2011-3591
- https://github.com/phpmyadmin/phpmyadmin/commit/bda213c58aec44925be661acb0e76c19483ea170
- https://bugzilla.redhat.com/show_bug.cgi?id=738681
- https://github.com/phpmyadmin/composer
- http://www.openwall.com/lists/oss-security/2011/09/30/8
- http://www.phpmyadmin.net/home_page/security/PMASA-2011-14.php