{"id":"GHSA-x2w2-qgv6-8xrm","aliases":["CVE-2018-16975"],"title":"Elefant CMS PHP Code Execution Vulnerability","description":"An issue was discovered in Elefant CMS before 2.0.7. There is a PHP Code Execution Vulnerability in `/designer/add/stylesheet.php` by using a `.php` extension in the New Stylesheet Name field in conjunction with `<?php` content, because of insufficient input validation in `apps/designer/handlers/csspreview.php`.","severity":"critical","score":9.8,"published":"2022-05-13T01:19:19.000Z","modified":"2024-04-23T23:11:43.195Z","withdrawn":false,"knownExploited":false,"affected":[{"ecosystem":"Packagist","name":"elefant/cms","ranges":[{"events":[{"introduced":"0"},{"fixed":"2.0.7"}],"type":"ECOSYSTEM"}],"versions":[],"fixed":["2.0.7"]}],"references":["https://nvd.nist.gov/vuln/detail/CVE-2018-16975","https://github.com/jbroadway/elefant/issues/286","https://github.com/jbroadway/elefant/commit/0795ab57c7ffa53ff4af57e229f6d9680fa54a21","https://github.com/jbroadway/elefant","https://github.com/jbroadway/elefant/releases/tag/elefant_2_0_7_stable"],"sources":[{"name":"OSV","id":"GHSA-x2w2-qgv6-8xrm","modified":"2024-04-23T23:11:43.195805Z","url":"https://osv.dev/vulnerability/GHSA-x2w2-qgv6-8xrm"}],"assessments":[{"source":"OSV","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":9.8}]}