{"id":"GHSA-wv8g-fx9j-q2jg","aliases":["CVE-2014-7217"],"title":"phpMyAdmin cross-site scripting Vulnerability via ENUM value","titleSource":"OSV","descriptionSource":"OSV","declaredSeverity":"LOW","description":"Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 4.0.x before 4.0.10.4, 4.1.x before 4.1.14.5, and 4.2.x before 4.2.9.1 allow remote authenticated users to inject arbitrary web script or HTML via a crafted ENUM value that is improperly handled during rendering of the (1) table search or (2) table structure page, related to `libraries/TableSearch.class.php` and `libraries/Util.class.php`.","severity":"low","score":null,"published":"2022-05-17T03:57:46.000Z","modified":"2024-11-29T05:41:42.764Z","withdrawn":false,"knownExploited":false,"affected":[{"ecosystem":"Packagist","name":"phpmyadmin/phpmyadmin","sources":[{"name":"OSV · GHSA-wv8g-fx9j-q2jg","url":"https://osv.dev/vulnerability/GHSA-wv8g-fx9j-q2jg"}],"ranges":[{"events":[{"introduced":"4.0.0"},{"fixed":"4.0.10.4"}],"type":"ECOSYSTEM"}],"versions":["4.0.0","4.0.1","4.0.10","4.0.10.1","4.0.10.2","4.0.10.3","4.0.2","4.0.3","4.0.4","4.0.4.1","4.0.4.2","4.0.5","4.0.6","4.0.7","4.0.8","4.0.9"],"fixed":["4.0.10.4"]},{"ecosystem":"Packagist","name":"phpmyadmin/phpmyadmin","sources":[{"name":"OSV · GHSA-wv8g-fx9j-q2jg","url":"https://osv.dev/vulnerability/GHSA-wv8g-fx9j-q2jg"}],"ranges":[{"events":[{"introduced":"4.1.0"},{"fixed":"4.1.14.5"}],"type":"ECOSYSTEM"}],"versions":[],"fixed":["4.1.14.5"]},{"ecosystem":"Packagist","name":"phpmyadmin/phpmyadmin","sources":[{"name":"OSV · GHSA-wv8g-fx9j-q2jg","url":"https://osv.dev/vulnerability/GHSA-wv8g-fx9j-q2jg"}],"ranges":[{"events":[{"introduced":"4.2.0"},{"fixed":"4.2.9.1"}],"type":"ECOSYSTEM"}],"versions":[],"fixed":["4.2.9.1"]}],"sourceAffected":[],"references":["https://nvd.nist.gov/vuln/detail/CVE-2014-7217","https://github.com/phpmyadmin/phpmyadmin/commit/304fb2b645b36a39e03b954fdbd567173ebe6448","https://github.com/phpmyadmin/phpmyadmin/commit/c1a3f85fbd1a9569646e7cf1b791325ae82c7961","https://web.archive.org/web/20141010205819/http://www.securityfocus.com/bid/70252","http://lists.opensuse.org/opensuse-updates/2014-10/msg00009.html","http://www.phpmyadmin.net/home_page/security/PMASA-2014-11.php"],"sources":[{"name":"OSV","id":"GHSA-wv8g-fx9j-q2jg","modified":"2024-11-29T05:41:42.764613Z","url":"https://osv.dev/vulnerability/GHSA-wv8g-fx9j-q2jg"}],"assessments":[],"products":[],"remediation":[],"kev":{"status":"not-listed","checkedAt":"2026-10-28T19:20:37.165Z"},"coverage":[{"source":"NVD","status":"not-checked"},{"source":"GHSA","status":"not-checked"},{"source":"EUVD","status":"not-checked"},{"source":"EPSS","status":"not-checked"}],"evidence":[]}