{"id":"GHSA-w6jr-wj64-mc9x","aliases":["BIT-codeigniter-2022-21647","CVE-2022-21647"],"title":"Deserialization of Untrusted Data in Codeigniter4","description":"### Impact\nDeserialization of Untrusted Data was found in the `old()` function in CodeIgniter4.\nRemote attackers may inject auto-loadable arbitrary objects with this vulnerability, \nand possibly execute existing PHP code on the server.\nWe are aware of a working exploit, which can lead to SQL injection.\n\n### Patches\nUpgrade to v4.1.6 or later.\n\n### Workarounds\nDo not use:\n- `old()` and form_helper\n- `RedirectResponse::withInput()` and `redirect()->withInput()`\n\n### References\n- [PHP Object Injection | OWASP](https://owasp.org/www-community/vulnerabilities/PHP_Object_Injection)\n\n### For more information\nIf you have any questions or comments about this advisory:\n* Open an issue in [codeigniter4/CodeIgniter4](https://github.com/codeigniter4/CodeIgniter4/issues)\n* Email us at [SECURITY.md](https://github.com/codeigniter4/CodeIgniter4/blob/develop/SECURITY.md)\n","severity":"high","score":7.7,"published":"2022-01-06T22:52:41.000Z","modified":"2024-02-16T08:17:56.625Z","withdrawn":false,"knownExploited":false,"affected":[{"ecosystem":"Packagist","name":"codeigniter4/framework","ranges":[{"events":[{"introduced":"0"},{"fixed":"4.1.6"}],"type":"ECOSYSTEM"}],"versions":["4.0.0","4.0.0-rc.4","v4.0.0-alpha.3","v4.0.0-alpha.4","v4.0.0-alpha.5","v4.0.0-beta.1","v4.0.0-beta.2","v4.0.0-beta.3","v4.0.0-beta.4","v4.0.0-rc.1","v4.0.0-rc.2","v4.0.0-rc.2.1","v4.0.0-rc.3","v4.0.1","v4.0.2","v4.0.3","v4.0.4","v4.0.5","v4.1.0","v4.1.1","v4.1.2","v4.1.3","v4.1.4","v4.1.5"],"fixed":["4.1.6"]}],"references":["https://github.com/codeigniter4/CodeIgniter4/security/advisories/GHSA-w6jr-wj64-mc9x","https://nvd.nist.gov/vuln/detail/CVE-2022-21647","https://github.com/codeigniter4/CodeIgniter4/commit/ce95ed5765256e2f09f3513e7d42790e0d6948f5","https://github.com/FriendsOfPHP/security-advisories/blob/master/codeigniter4/framework/CVE-2022-21647.yaml","https://github.com/codeigniter4/CodeIgniter4"],"sources":[{"name":"OSV","id":"GHSA-w6jr-wj64-mc9x","modified":"2024-02-16T08:17:56.625554Z","url":"https://osv.dev/vulnerability/GHSA-w6jr-wj64-mc9x"}],"assessments":[{"source":"OSV","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:H/A:H","score":7.7}]}