{"id":"GHSA-vm6p-35rw-3fxc","aliases":["CVE-2022-2713"],"title":"Cockpit before 2.2.0 vulnerable to Insufficient Session Expiration","description":"Cockpit before version 2.2.0 is vulnerable to Insufficient Session Expiration. The application does not validate requests after password changes, allowing a user to change their account details even after an admin changes their password.","severity":"critical","score":9.8,"published":"2022-08-09T00:00:25.000Z","modified":"2023-11-08T04:08:56.146Z","withdrawn":false,"knownExploited":false,"affected":[{"ecosystem":"Packagist","name":"aheinze/cockpit","ranges":[{"events":[{"introduced":"0"},{"fixed":"2.2.0"}],"type":"ECOSYSTEM"}],"versions":["0.10.0","0.10.1","0.10.2","0.11.0","0.11.1","0.11.2","0.12.0","0.12.1","0.12.2","0.6.0","0.6.1","0.6.2","0.7.0","0.7.1","0.7.2","0.8.0","0.8.1","0.8.10","0.8.11","0.8.2","0.8.3","0.8.4","0.8.6","0.8.7","0.8.8","0.8.9","0.9.0","0.9.1","0.9.2","0.9.3"],"fixed":["2.2.0"]}],"references":["https://nvd.nist.gov/vuln/detail/CVE-2022-2713","https://github.com/cockpit-hq/cockpit/commit/dd8d0314912fa6517ebd2cc9939d9fafbe68731b","https://github.com/cockpit-hq/cockpit","https://huntr.dev/bounties/3080fc96-75d7-4868-84de-9fc8c9b90290"],"sources":[{"name":"OSV","id":"GHSA-vm6p-35rw-3fxc","modified":"2023-11-08T04:08:56.146982Z","url":"https://osv.dev/vulnerability/GHSA-vm6p-35rw-3fxc"}],"assessments":[{"source":"OSV","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":9.8}]}