{"id":"GHSA-vcq7-x4wr-w2mj","aliases":["CVE-2011-2509"],"title":"Joomla! vulnerable to Cross-site Scripting","description":"Multiple cross-site scripting (XSS) vulnerabilities in Joomla! before 1.6.4 allow remote attackers to inject arbitrary web script or HTML via (1) the query string to the com_contact component, as demonstrated by the Itemid parameter to index.php; (2) the query string to the com_content component, as demonstrated by the filter_order parameter to index.php; (3) the query string to the com_newsfeeds component, as demonstrated by an arbitrary parameter to index.php; or (4) the option parameter in a reset.request action to index.php; and, when Internet Explorer or Konqueror is used, (5) allow remote attackers to inject arbitrary web script or HTML via the searchword parameter in a search action to index.php in the com_search component.","severity":"medium","score":5.3,"published":"2022-05-14T03:08:10.000Z","modified":"2025-04-12T02:42:07.438Z","withdrawn":false,"knownExploited":false,"affected":[{"ecosystem":"Packagist","name":"joomla/joomla-cms","ranges":[{"events":[{"introduced":"0"},{"fixed":"1.6.4"}],"type":"ECOSYSTEM"}],"versions":[],"fixed":["1.6.4"]}],"references":["https://nvd.nist.gov/vuln/detail/CVE-2011-2509","http://developer.joomla.org/security/news/352-20110604-xss-vulnerability.html","http://www.openwall.com/lists/oss-security/2011/06/28/4","http://www.openwall.com/lists/oss-security/2011/06/29/12","http://yehg.net/lab/pr0js/advisories/joomla/core/%5Bjoomla_1.6.3%5D_cross_site_scripting%28XSS%29"],"sources":[{"name":"OSV","id":"GHSA-vcq7-x4wr-w2mj","modified":"2025-04-12T02:42:07.438830Z","url":"https://osv.dev/vulnerability/GHSA-vcq7-x4wr-w2mj"}],"assessments":[{"source":"OSV","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N","score":5.3}]}