{"id":"GHSA-v99w-jxr4-w6mc","aliases":["CVE-2019-8117"],"title":"Magento 2 Community Edition XSS Vulnerability","description":"A stored cross-site scripting (XSS) vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticates user can inject arbitrary JavaScript code via product view id specification.","severity":"medium","score":5.4,"published":"2022-05-24T17:00:25.000Z","modified":"2024-02-16T08:18:28.080Z","withdrawn":false,"knownExploited":false,"affected":[{"ecosystem":"Packagist","name":"magento/community-edition","ranges":[{"events":[{"introduced":"2.2.0"},{"fixed":"2.2.10"}],"type":"ECOSYSTEM"}],"versions":["2.2.0","2.2.1","2.2.2","2.2.3","2.2.4","2.2.5","2.2.6","2.2.7","2.2.8","2.2.9"],"fixed":["2.2.10"]},{"ecosystem":"Packagist","name":"magento/community-edition","ranges":[{"events":[{"introduced":"2.3.0"},{"fixed":"2.3.2-p1"}],"type":"ECOSYSTEM"}],"versions":["2.3.0","2.3.1","2.3.2"],"fixed":["2.3.2-p1"]}],"references":["https://nvd.nist.gov/vuln/detail/CVE-2019-8117","https://github.com/FriendsOfPHP/security-advisories/blob/master/magento/product-community-edition/CVE-2019-8117.yaml","https://github.com/magento/magento2","https://magento.com/security/patches/magento-2.3.3-and-2.2.10-security-update","https://web.archive.org/web/20220121051105/https://magento.com/security/patches/magento-2.3.3-and-2.2.10-security-update"],"sources":[{"name":"OSV","id":"GHSA-v99w-jxr4-w6mc","modified":"2024-02-16T08:18:28.080376Z","url":"https://osv.dev/vulnerability/GHSA-v99w-jxr4-w6mc"}],"assessments":[{"source":"OSV","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","score":5.4}]}