{"id":"GHSA-rwgm-f83r-v3qj","aliases":["BIT-wp-cli-2021-29504","CVE-2021-29504"],"title":"Improper Certificate Validation in WP-CLI framework","description":"### Impact\nAn improper error handling in HTTPS requests management in WP-CLI version 0.12.0 and later allows remote attackers able to intercept the communication to remotely disable the certificate verification on WP-CLI side, gaining full control over the communication content, including the ability to impersonate update servers and push malicious updates towards WordPress instances controlled by the vulnerable WP-CLI agent, or push malicious updates toward WP-CLI itself.\n\n### Patches\nThe vulnerability stems from the fact that the default behavior of `WP_CLI\\Utils\\http_request()` when encountering a TLS handshake error is to disable certificate validation and retry the same request.\n\nThe default behavior has been changed with version 2.5.0 of WP-CLI and the `wp-cli/wp-cli` framework (via https://github.com/wp-cli/wp-cli/pull/5523) so that the `WP_CLI\\Utils\\http_request()` method accepts an `$insecure` option that is `false` by default and consequently that a TLS handshake failure is a hard error by default. This new default is a breaking change and ripples through to all consumers of `WP_CLI\\Utils\\http_request()`, including those in separate WP-CLI bundled or third-party packages.\n\nhttps://github.com/wp-cli/wp-cli/pull/5523 has also added an `--insecure` flag to the `cli update` command to counter this breaking change.\n\nSubsequent PRs on the command repositories have added an `--insecure` flag to the appropriate commands on the following repositories to counter the breaking change:\n\n* https://github.com/wp-cli/config-command/pull/128\n* https://github.com/wp-cli/core-command/pull/186\n* https://github.com/wp-cli/extension-command/pull/287\n* https://github.com/wp-cli/checksum-command/pull/86\n* https://github.com/wp-cli/package-command/pull/138\n\n### Workarounds\nThere is no direct workaround for the default insecure behavior of `wp-cli/wp-cli` versions before 2.5.0.\n\nThe workaround for dealing with the breaking change in the commands directly affected by the new secure default behavior is to add the `--insecure` flag to manually opt-in to the previous insecure behavior.\n\n### References\n* [CWE: Improper Certificate Validation](https://cwe.mitre.org/data/definitions/295.html)\n\n### For more information\nIf you have any questions or comments about this advisory:\n* Join the `#cli` channel in the [WordPress.org Slack](https://make.wordpress.org/chat/) to ask questions or provide feedback.\n","severity":"critical","score":9.1,"published":"2021-05-19T23:03:11.000Z","modified":"2026-07-08T06:28:33.162Z","withdrawn":false,"knownExploited":false,"affected":[{"ecosystem":"Packagist","name":"wp-cli/wp-cli","ranges":[{"events":[{"introduced":"0.12.0"},{"fixed":"2.5.0"}],"type":"ECOSYSTEM"}],"versions":["v0.12.0","v0.12.1","v0.13.0","v0.14.0","v0.14.1","v0.15.0","v0.15.1","v0.16.0","v0.17.0","v0.17.1","v0.17.2","v0.18.0","v0.18.1","v0.19.0","v0.19.1","v0.19.2","v0.19.3","v0.20.0","v0.20.1","v0.20.2","v0.20.3","v0.20.4","v0.21.0","v0.21.1","v0.22.0","v0.23.0","v0.23.1","v0.24.0","v0.24.1","v0.25.0","v1.0.0","v1.1.0","v1.2.0","v1.2.1","v1.3.0","v1.4.0","v1.4.1","v1.5.0","v1.5.1","v2.0.0","v2.0.1","v2.1.0","v2.2.0","v2.3.0","v2.4.0","v2.4.1"],"fixed":["2.5.0"]}],"references":["https://github.com/wp-cli/wp-cli/security/advisories/GHSA-rwgm-f83r-v3qj","https://nvd.nist.gov/vuln/detail/CVE-2021-29504","https://github.com/wp-cli/checksum-command/pull/86","https://github.com/wp-cli/config-command/pull/128","https://github.com/wp-cli/core-command/pull/186","https://github.com/wp-cli/extension-command/pull/287","https://github.com/wp-cli/package-command/pull/138","https://github.com/wp-cli/wp-cli/pull/5523","https://github.com/FriendsOfPHP/security-advisories/blob/master/wp-cli/wp-cli/CVE-2021-29504.yaml"],"sources":[{"name":"OSV","id":"GHSA-rwgm-f83r-v3qj","modified":"2026-07-08T06:28:33.162076980Z","url":"https://osv.dev/vulnerability/GHSA-rwgm-f83r-v3qj"}],"assessments":[{"source":"OSV","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N","score":9.1}]}