{"id":"GHSA-rqgj-rqfr-5j6f","aliases":["CVE-2022-26144"],"title":"MantisBT vulnerable to XSS due to improper escape in manage_plugin_page.php and manage_plugin_uninstall.php","description":"An XSS issue was discovered in MantisBT before 2.25.3. Improper escaping of a Plugin name allows execution of arbitrary code (if CSP allows it) in manage_plugin_page.php and manage_plugin_uninstall.php when a crafted plugin is installed.","severity":"medium","score":6.1,"published":"2022-04-14T00:00:19.000Z","modified":"2025-06-09T22:42:05.025Z","withdrawn":false,"knownExploited":false,"affected":[{"ecosystem":"Packagist","name":"mantisbt/mantisbt","ranges":[{"events":[{"introduced":"0"},{"fixed":"2.25.3"}],"type":"ECOSYSTEM"}],"versions":["2.10.0","2.10.1","2.11.0","2.11.1","2.12.0","2.12.1","2.12.2","2.13.0","2.13.1","2.13.2","2.14.0","2.15.0","2.15.1","2.16.0","2.16.1","2.17.0","2.17.1","2.17.2","2.18.0","2.18.1","2.19.0","2.19.1","2.20.0","2.20.1","2.21.0","2.21.1","2.21.2","2.21.3","2.22.0","2.22.1","2.22.2","2.23.0","2.23.1","2.24.0","2.24.1","2.24.2","2.24.3","2.24.4","2.24.5","2.25.0","2.25.1","2.25.2","2.3.0","2.3.1","2.3.2","2.3.3","2.4.0","2.4.1","2.4.2","2.5.0","2.5.1","2.5.2","2.6.0","2.7.0","2.7.1","2.8.0","2.8.1","2.9.0","2.9.1"],"fixed":["2.25.3"]}],"references":["https://nvd.nist.gov/vuln/detail/CVE-2022-26144","https://github.com/mantisbt/mantisbt/commit/a7751c3e318011ca1314bc1cfea200d53e0dfff6","https://github.com/mantisbt/mantisbt","https://mantisbt.org/bugs/view.php?id=29688"],"sources":[{"name":"OSV","id":"GHSA-rqgj-rqfr-5j6f","modified":"2025-06-09T22:42:05.025441Z","url":"https://osv.dev/vulnerability/GHSA-rqgj-rqfr-5j6f"}],"assessments":[{"source":"OSV","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","score":6.1}]}