{"id":"GHSA-pvr5-84gr-g985","aliases":["CVE-2014-8326"],"title":"phpMyAdmin Implementation XSS Vulnerability on Server Monitor Page","description":"Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 4.0.x before 4.0.10.5, 4.1.x before 4.1.14.6, and 4.2.x before 4.2.10.1 allow remote authenticated users to inject arbitrary web script or HTML via a crafted (1) database name or (2) table name, related to the `libraries/DatabaseInterface.class.php` code for SQL debug output and the `js/server_status_monitor.js` code for the server monitor page.","severity":"medium","score":null,"published":"2022-05-14T02:05:34.000Z","modified":"2024-12-08T05:30:35.816Z","withdrawn":false,"knownExploited":false,"affected":[{"ecosystem":"Packagist","name":"phpmyadmin/phpmyadmin","ranges":[{"events":[{"introduced":"4.0.0"},{"fixed":"4.0.10.5"}],"type":"ECOSYSTEM"}],"versions":["4.0.0","4.0.1","4.0.10","4.0.10.1","4.0.10.2","4.0.10.3","4.0.10.4","4.0.2","4.0.3","4.0.4","4.0.4.1","4.0.4.2","4.0.5","4.0.6","4.0.7","4.0.8","4.0.9"],"fixed":["4.0.10.5"]},{"ecosystem":"Packagist","name":"phpmyadmin/phpmyadmin","ranges":[{"events":[{"introduced":"4.1.0"},{"fixed":"4.1.14.6"}],"type":"ECOSYSTEM"}],"versions":[],"fixed":["4.1.14.6"]},{"ecosystem":"Packagist","name":"phpmyadmin/phpmyadmin","ranges":[{"events":[{"introduced":"4.2.0"},{"fixed":"4.2.10.1"}],"type":"ECOSYSTEM"}],"versions":[],"fixed":["4.2.10.1"]}],"references":["https://nvd.nist.gov/vuln/detail/CVE-2014-8326","https://github.com/phpmyadmin/phpmyadmin/commit/7b8962dede7631298c81e2c1cd267b81f1e08a8c","https://github.com/phpmyadmin/phpmyadmin/commit/bd68c54d1beeef79d237e8bfda44690834012a76","https://web.archive.org/web/20200228163625/http://www.securityfocus.com/bid/70731","http://lists.opensuse.org/opensuse-updates/2014-11/msg00004.html","http://www.phpmyadmin.net/home_page/security/PMASA-2014-12.php"],"sources":[{"name":"OSV","id":"GHSA-pvr5-84gr-g985","modified":"2024-12-08T05:30:35.816122Z","url":"https://osv.dev/vulnerability/GHSA-pvr5-84gr-g985"}],"assessments":[]}