{"id":"GHSA-m6m8-6gq8-c9fj","aliases":["BIT-codeigniter-2023-32692","CVE-2023-32692"],"title":"Remote Code Execution Vulnerability in Validation Placeholders in CodeIgniter4","description":"### Impact\nThis vulnerability allows attackers to execute arbitrary code when you use Validation Placeholders.\n\nThe vulnerability exists in the Validation library, and validation methods in the controller and in-model validation are also vulnerable because they use the Validation library internally.\n\n### Patches\nUpgrade to v4.3.5 or later.\n\n### Workarounds\nSetting validation rules with an array.\n\nE.g.:\n```php\n$validation->setRules([\n    'email' => ['required', 'valid_email, 'is_unique[users.email,id,{id}]'],\n]);\n```\n\n### References\n- https://codeigniter4.github.io/userguide/libraries/validation.html#validation-placeholders\n- https://codeigniter4.github.io/userguide/incoming/controllers.html#validating-data\n- https://codeigniter4.github.io/userguide/models/model.html#in-model-validation\n\n### For more information\nIf you have any questions or comments about this advisory:\n* Open an issue in [codeigniter4/CodeIgniter4](https://github.com/codeigniter4/CodeIgniter4/issues)\n* Email us at [SECURITY.md](https://github.com/codeigniter4/CodeIgniter4/blob/develop/SECURITY.md)\n","severity":"critical","score":9.8,"published":"2023-05-22T19:49:11.000Z","modified":"2026-09-10T03:50:01.648Z","withdrawn":false,"knownExploited":false,"affected":[{"ecosystem":"Packagist","name":"codeigniter4/framework","ranges":[{"events":[{"introduced":"0"},{"fixed":"4.3.5"}],"type":"ECOSYSTEM"}],"versions":["4.0.0","4.0.0-rc.4","v4.0.0-alpha.3","v4.0.0-alpha.4","v4.0.0-alpha.5","v4.0.0-beta.1","v4.0.0-beta.2","v4.0.0-beta.3","v4.0.0-beta.4","v4.0.0-rc.1","v4.0.0-rc.2","v4.0.0-rc.2.1","v4.0.0-rc.3","v4.0.1","v4.0.2","v4.0.3","v4.0.4","v4.0.5","v4.1.0","v4.1.1","v4.1.2","v4.1.3","v4.1.4","v4.1.5","v4.1.6","v4.1.7","v4.1.8","v4.1.9","v4.2.0","v4.2.1","v4.2.10","v4.2.11","v4.2.12","v4.2.2","v4.2.3","v4.2.4","v4.2.5","v4.2.6","v4.2.7","v4.2.8","v4.2.9","v4.3.0","v4.3.1","v4.3.2","v4.3.3","v4.3.4"],"fixed":["4.3.5"]}],"sourceAffected":[],"references":["https://github.com/codeigniter4/CodeIgniter4/security/advisories/GHSA-m6m8-6gq8-c9fj","https://nvd.nist.gov/vuln/detail/CVE-2023-32692","https://github.com/codeigniter4/CodeIgniter4/commit/6af677177fa1d9ad62f7a793bc96cba3068632ba","https://github.com/codeigniter4/CodeIgniter4","https://github.com/codeigniter4/CodeIgniter4/blob/develop/CHANGELOG.md","https://github.com/codeigniter4/CodeIgniter4/blob/develop/CHANGELOG.md#v435-2023-05-21"],"sources":[{"name":"OSV","id":"GHSA-m6m8-6gq8-c9fj","modified":"2026-09-10T03:50:01.648652628Z","url":"https://osv.dev/vulnerability/GHSA-m6m8-6gq8-c9fj"}],"assessments":[{"source":"OSV","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":9.8}]}