{"id":"GHSA-j8mx-x32r-5rf4","aliases":["CVE-2016-9856"],"title":"phpMyAdmin XSS Vulnerability","description":"An XSS issue was discovered in phpMyAdmin because of an improper fix for CVE-2016-2559 in PMASA-2016-10. This issue is resolved by using a copy of a hash to avoid a race condition. All 4.6.x versions (prior to 4.6.5), 4.4.x versions (prior to 4.4.15.9), and 4.0.x versions (prior to 4.0.10.18) are affected.","severity":"medium","score":6.1,"published":"2022-05-17T02:36:37.000Z","modified":"2024-02-16T08:07:07.796Z","withdrawn":false,"knownExploited":false,"affected":[{"ecosystem":"Packagist","name":"phpmyadmin/phpmyadmin","ranges":[{"events":[{"introduced":"4.6"},{"fixed":"4.6.5"}],"type":"ECOSYSTEM"}],"versions":[],"fixed":["4.6.5"]},{"ecosystem":"Packagist","name":"phpmyadmin/phpmyadmin","ranges":[{"events":[{"introduced":"4.4"},{"fixed":"4.4.15.9"}],"type":"ECOSYSTEM"}],"versions":[],"fixed":["4.4.15.9"]},{"ecosystem":"Packagist","name":"phpmyadmin/phpmyadmin","ranges":[{"events":[{"introduced":"4.0"},{"fixed":"4.0.10.18"}],"type":"ECOSYSTEM"}],"versions":["4.0.0","4.0.1","4.0.10","4.0.10.1","4.0.10.2","4.0.10.3","4.0.10.4","4.0.10.5","4.0.10.6","4.0.10.7","4.0.10.8","4.0.10.9","4.0.2","4.0.3","4.0.4","4.0.4.1","4.0.4.2","4.0.5","4.0.6","4.0.7","4.0.8","4.0.9"],"fixed":["4.0.10.18"]}],"references":["https://nvd.nist.gov/vuln/detail/CVE-2016-9856","https://security.gentoo.org/glsa/201701-32","https://web.archive.org/web/20210123194716/http://www.securityfocus.com/bid/94530","https://www.phpmyadmin.net/security/PMASA-2016-64"],"sources":[{"name":"OSV","id":"GHSA-j8mx-x32r-5rf4","modified":"2024-02-16T08:07:07.796408Z","url":"https://osv.dev/vulnerability/GHSA-j8mx-x32r-5rf4"}],"assessments":[{"source":"OSV","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","score":6.1}]}