{"id":"GHSA-h6px-pvfh-q2jv","aliases":["CVE-2011-4299"],"title":"Moodle vulnerable to Cross-Site Scripting","description":"Cross-site scripting (XSS) vulnerability in mod/wiki/pagelib.php in Moodle 2.0.x before 2.0.5 and 2.1.x before 2.1.2 allows remote authenticated users to inject arbitrary web script or HTML via a wiki comment.","severity":"low","score":1.2,"published":"2022-05-13T01:13:15.000Z","modified":"2025-04-12T02:57:07.168Z","withdrawn":false,"knownExploited":false,"affected":[{"ecosystem":"Packagist","name":"moodle/moodle","ranges":[{"events":[{"introduced":"2.0.0"},{"fixed":"2.0.5"}],"type":"ECOSYSTEM"}],"versions":[],"fixed":["2.0.5"]},{"ecosystem":"Packagist","name":"moodle/moodle","ranges":[{"events":[{"introduced":"2.1.0"},{"fixed":"2.1.2"}],"type":"ECOSYSTEM"}],"versions":[],"fixed":["2.1.2"]}],"references":["https://nvd.nist.gov/vuln/detail/CVE-2011-4299","https://bugzilla.redhat.com/show_bug.cgi?id=747444","https://git.moodle.org","http://git.moodle.org/gw?p=moodle.git%3Ba=commit%3Bh=a459fd90625ae44d7b3ac10b65da2dc631a418e7","http://git.moodle.org/gw?p=moodle.git;a=commit;h=a459fd90625ae44d7b3ac10b65da2dc631a418e7","http://moodle.org/mod/forum/discuss.php?d=188310"],"sources":[{"name":"OSV","id":"GHSA-h6px-pvfh-q2jv","modified":"2025-04-12T02:57:07.168196Z","url":"https://osv.dev/vulnerability/GHSA-h6px-pvfh-q2jv"}],"assessments":[{"source":"OSV","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:U","score":1.2}]}